Welcome, Guest
Please Login or Register.    Lost Password?

rPlay beta bug reports and feedbacks
(1 viewing) (1) Guest
Go to bottomPage: 1...73747576777879...103
TOPIC: rPlay beta bug reports and feedbacks
*
#14366
Re:rPlay beta bug reports and feedbacks 6 Years, 5 Months ago Karma: 0
---
rickdeny
Junior Boarder
Posts: 21
graphgraph
User Offline Click here to see the profile of this user
Last Edit: 2013/12/28 22:12 By rickdeny.
The administrator has disabled public write access.
 
#14372
Re:rPlay beta bug reports and feedbacks 6 Years, 5 Months ago Karma: 0
Thanks for working on this app. Once I get it working, I'll have several uses for it. Unfortunately, I am having trouble getting rPlay to work properly.

rPlay is seen as an audio destination by my Apple TV and by iTunes running 2 Macs and a Windows PC. However, neither the macs nor my iOS devices can see rPlay for any kind of playback.

The RPi is connected via Ethernet. As is the Apple TV, Windows PC, and my Mac Mini (Mavericks). My MacBook Air (Mavericks) is connected via WiFi as are (Obviously) my iOS devices. They are:

- iPad 2 (iOS 7.0.4)
- iPad Air (iOS 7.0.4)
- iPhone 4s (iOS 7.0.4)
- iPhone 4s (iOS 6.1.3)

I do not see rPlay from the mirroring panel or from any apps. I do see the Apple TV and each of the Macs. (Running AirServer)

I do not see rPlay from the display panel on either of the Macs, Again, I do see the Apple TV and the other Mac. (Running AirServer)

It doesn't appear that rPlay has a log file. Here is the output from running the executable.

pi@raspberrypi ~ $ sudo /usr/bin/rplay
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.front
*** WARNING *** The program 'rplay' uses the Apple Bonjour compatibility layer of Avahi.
*** WARNING *** Please fix your application to use the native API of Avahi!
*** WARNING *** For more information see <0pointer.de/avahi-compat?s=libdns_sd&e=rplay>


I understand that the Avahi warnings are normal. What about the PCM message?

Could this be a licensing issue? I've added the license key as instructed. Is there any other info I could provide?

Note: I've built fresh installs of Raspbian twice and have followed the instructions each time. Not sure what I'm missing..

Any help would be greatly appreciated.
John-Video
Fresh Boarder
Posts: 1
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#14374
Re:rPlay beta bug reports and feedbacks 6 Years, 5 Months ago Karma: 0
rickdeny wrote:
Hello!
I'm so glad to get the key for rPlay this morning.
I test it via VNC from my Mac works well while pi connect with cable
But after i setup everything (use wifi replace cable,connect to display via HDMI) it doesn't work.
Once i tried to reset the program i got the warning msg as follow.

*** WARNING *** Please fix your application to use the native API of Avahi!
*** WARNING *** For more information see <0pointer.de/avahi-compat?s=libdns_sd&e=rplay>
*** WARNING *** The program 'rplay' uses the Apple Bonjour compatibility layer of Avahi.


even i use apt-get command to install other program it will be shawn.

The problem for me right now is my Mac cannot find the airplay service .



UPDATE ==2013-12-29 00:12:59==
I use cable to replace the wifi adapter but it didn't work.
And the warning massage are shown ceaselessly in the screen whatever login or installing program.
I tried to uninstall and re-install the rplay but it doesn't work.
rickdeny
Junior Boarder
Posts: 21
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#14378
Re:rPlay beta bug reports and feedbacks 6 Years, 5 Months ago Karma: 0
rickdeny wrote:
rickdeny wrote:
Hello!
I'm so glad to get the key for rPlay this morning.
I test it via VNC from my Mac works well while pi connect with cable
But after i setup everything (use wifi replace cable,connect to display via HDMI) it doesn't work.
Once i tried to reset the program i got the warning msg as follow.

*** WARNING *** Please fix your application to use the native API of Avahi!
*** WARNING *** For more information see <0pointer.de/avahi-compat?s=libdns_sd&e=rplay>
*** WARNING *** The program 'rplay' uses the Apple Bonjour compatibility layer of Avahi.


even i use apt-get command to install other program it will be shawn.

The problem for me right now is my Mac cannot find the airplay service .



UPDATE ==2013-12-29 00:12:59==
I use cable to replace the wifi adapter but it didn't work.
And the warning massage are shown ceaselessly in the screen whatever login or installing program.
I tried to uninstall and re-install the rplay but it doesn't work.



Update ======2013-12-29 03:48:04======
I format my sd card and re-install all the system
follow the instructions via email but i met the same problem.
I update the system, install tightvncserver and vim.
I still get the warring msg
*** WARNING *** The program 'rplay' uses the Apple Bonjour compatibility layer of Avahi.
*** WARNING *** Please fix your application to use the native API of Avahi!
*** WARNING *** For more information see <0pointer.de/avahi-compat?s=libdns_sd&e=rplay>


Then i tried to use command
Code:

pi@raspberrypi ~ $  sudo /usr/bin/rplay
Another instance using port 7100 is running, please kill it first. Exit now...




I check the port via

Code:

pi@raspberrypi ~ $ netstat -ap | grep 7100
(Not all processes could be identified, non-owned process info
 will not be shown, you would have to be root to see it all.)



I got nothing while use sudo to run the command above.

None of my Ipad2/Macbook Pro/Iphone5 find the airplay service

My test env:
Pi connected with Ethernet
The others connect to wifi but same router
IPAD 2 - IOS6
IPHONE 5 -IOS7
MAC- Mavericks
Appreciate any suggestions
rickdeny
Junior Boarder
Posts: 21
graphgraph
User Offline Click here to see the profile of this user
Last Edit: 2013/12/29 02:37 By rickdeny.
The administrator has disabled public write access.
 
#14440
Re:rPlay beta bug reports and feedbacks 6 Years, 4 Months ago Karma: 0
Hi,

So after I successfully installed rPlay on my beautiful Raspberry Pi, there is quite a big Problem.
I have got a iPhone 5 with iOS 7.0.4 installed on it and it seems, that rPlay isn't compatible to iOS 7.0.4.
When I try to mirror my Screen my raspberry is listed in the AirPlay reciever Devices (along with two Apple-TVs).
When I click on that raspberry to AirPlay my screen, it seems to be selected but there isn't any change on my TV. After some seconds the iPhone automatically deselects the raspberry and changes back to iPhone.
Is this going to be fixed in the future, because I'm really excited

EDIT: I found the problem with AirPlay-Mirroring. See the log above:
Code:

raop connection init(conn=0x207ca40)
failed to connect to server: test.vmlite.com:9080
raop connection destroy:conn=0x207ca40



It seems that test.vmlite.com is down, because i couldn't ping it...

Marco Kolb
anon_freak
Fresh Boarder
Posts: 5
graphgraph
User Offline Click here to see the profile of this user
Last Edit: 2013/12/31 05:05 By anon_freak.Reason: Found Problem
The administrator has disabled public write access.
 
#14445
Re:rPlay beta bug reports and feedbacks 6 Years, 4 Months ago Karma: 86
Hi anon_freak,

can you try it again? We have recently changed DNS entry for test.vmlite.com, it may take a few days for the update.
huisinro
Moderator
Posts: 1567
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
Go to topPage: 1...73747576777879...103